[ipxe-devel] Connection reset (0f0a6039)

Lee Bradshaw lee at witsend.id.au
Fri Feb 4 22:08:22 UTC 2011

This becomes more interesting.

I obtained an oldish version of GPXE from somewhere; this was able to
connect to the iSCSI disk on the FreeNAS server just fine. Unfortunately,
the BIOS on the workstation I have doesn't fall back to the next boot
device, so I haven't been able to use it to install Windows to the iSCSI
target. I tried using Ctrl-B after it hooked the drive to get it to load
WinPE from another image on the TFTP server, but it just hung if it had
hooked an iSCSI drive first - worked OK if I did it on its own.

So I bit the bullet and created a Unix machine and built the latest gPXE
from source; an interesting new experience for me. This version has the same
problem as the current iPXE: "Could not open SAN device: connection reset

Also built the latest iPXE from source to check, and still the same problem.

So I can rule out firewalls and network problems, as the old gPXE was able
to hook the drive - and so can other Windows machines on the network. It
appears that something done between gPXE 0.9.3 (I think it was) and 1.0.1
has introduced a problem when talking to FreeNAS.

Any suggestions would be welcome.


-----Original Message-----
From: Michael Brown [mailto:mbrown at fensystems.co.uk] 
Sent: Friday, 28 January 2011 10:15 PM
To: ipxe-devel at lists.ipxe.org
Cc: Lee Bradshaw
Subject: Re: [ipxe-devel] Connection reset (0f0a6039)

On Friday 28 Jan 2011 08:25:02 Lee Bradshaw wrote:
> I'm trying to set up a diskless Windows 7 workstation.
> I've set up FreeNas in a VM on a windows 2008 machine; I've set up the 
> TFTP server & DHCP entries on the DHCP server (a Windows 2003 machine).
> I then created a volume in FreeNas, connected to it from a Windows 7 
> machine, and cloned the system disk to it; then disconnected the iScsi 
> drive.
> In order to test it, I created a second VM machine on the Windows 2008 
> machine, with no operating system; the DHCP entries are set up to 
> point  this to iPXE then the iSCSI drive I created on FreeNas.
> It loads undionly as expected, then tries to boot the iSCSI volume, 
> but I
> get:
> Root path: iscsi:
> Could not open SAN device: connection reset (http://ipxe.org/0f0a6039)

Kudos for already trying the latest version of iPXE; I can tell from the
output that you're using a version less than 12 hours old!  :)

> The FreeNas logs don't show anything happening at all.
> Any help would be appreciated.

I assume you've already seen the advice on http://ipxe.org/0f0a6039?  This
sounds like a firewall issue.  If you look at a packet capture you should
see that iPXE is sending a SYN and the target is responding immediately with
a RST.  That would explain why nothing shows up in the FreeNas logs; the
connection is rejected by the firewall before it reaches FreeNas.

Try disabling the firewall on the Windows 2008 VM hosting FreeNas.  If this
doesn't help, try capturing a packet trace (http://ipxe.org/howto/pcap) on
that VM; that might show what's happening.


More information about the ipxe-devel mailing list