[ipxe-devel] cannot boot memtest86+

Michael Stumpf mjstumpf at gmail.com
Sun Apr 10 13:04:31 UTC 2011

That worked great -- thanks.  While unnecessary, I appreciate you taking the
time to point out how easy it is to build memtest, because I had problems
(and it suggested to me that this is uncommon/there is an easy fix).

Building memtest on an x64 system didn't work, because there is an
assumption that /usr/include/gnu/stubs-32.h is present.  Move to a 32-bit
machine, problem solved.

Also, I suggest that maybe you post a note about this more conspicuously.  I
spent quite a while googling "ipxe memtest", as well as more refined
searches, before asking.

Thanks again-

On Sun, Apr 10, 2011 at 2:44 AM, Michael Brown <mbrown at fensystems.co.uk>wrote:

> On Sunday 10 Apr 2011 08:29:58 Michael Brown wrote:
> > > Are there any other workarounds / other ways to load?  (Flashing NIC
> ROMs
> > >  is not practical for me)
> >
> > You can use the ELF-format version of memtest86+ instead of the
> >  zImage-format version.  This loads much lower in memory (0x5000 rather
> >  than 0x90000) and so will avoid the collision.
> >
> > The ELF version doesn't seem to be available as a prebuilt binary, but if
> >  you download the memtest86+ source code and type "make", it will build
> all
> >  formats for you.  The one you want is the binary called just "memtest".
> I've updated http://ipxe.org/46038101 to specifically mention this memtest
> issue.  Please let me know if the instructions do or do not work for you.
> Thanks,
> Michael
> _______________________________________________
> ipxe-devel mailing list
> ipxe-devel at lists.ipxe.org
> https://lists.ipxe.org/mailman/listinfo/ipxe-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20110410/7bf7146f/attachment.htm>

More information about the ipxe-devel mailing list