[ipxe-devel] I have a trouble booting iPXE from a specific laptop

Esben Storgaard Nielsen esn at solar.dk
Wed Dec 21 11:14:39 GMT 2016


Hi Again

I is correct, ipxe.pxe run only 10MB and using the ipxe.i219+lm2.pxe change it back to 1G speed again.

I know it is difficult to struggle with one, that knows anything about building software, but I have no clue how to do it!

That’s why the rom-o-magic is an easy toll to use.

Is there a guide hoe to build the ipxe.pxe and how does I implement my menu?

That is my menu used by undionly.kpxe

#!ipxe
dhcp
:MENU
menu
item --gap -- ---------------- Install media ----------------
item SCCM-64-bit       	Boot to Normal computer install

item --gap -- ---------------- Tools ----------------
item DiskWipe		Boot to DiskWipe
item hostinfo		Show host information

choose --default return --timeout 30000 target && goto ${target}
 
:SCCM-64-bit
chain http://ppxes001.sgcorpnet.com/SCCM/SCCM-Boot-x64/sccm.ipxe ||
goto MENU

:DiskWipe
chain http://ppxes001.sgcorpnet.com/Tools/DiskWipe/diskwipe.ipxe ||
goto MENU

:hostinfo
echo This computer : ||
echo MAC address....${net0/mac} ||
echo IP address.....${ip} ||
echo Netmask........${netmask} ||
echo Serial.........${serial} ||
echo Asset number...${asset} ||
echo Manufacturer...${manufacturer} ||
echo Product........${product} ||
echo BIOS platform..${platform} ||
echo ||
echo press any key to return to Menu ||
prompt
goto MENU
 
autoboot



How can I help, digging much deeper to the debug of Undionly.kpxe?

I will contact Lenovo about the problem again.

Med venlig hilsen / Kind regards,

Esben Storgaard Nielsen
Systems Administrator, Server

Solar A/S
Industrivej Vest 43
6600 Vejen

Phone Direct +45 79300314
Fax          
Mobile       +45 40342836
E-mail       esn at solar.dk
Internet     www.solar.eu
-----Original Message-----
From: Christian Nilsson [mailto:nikize at gmail.com] 
Sent: 20. december 2016 23:21
To: Esben Storgaard Nielsen <esn at solar.dk>; Richard Moore <rich at richud.com>
Cc: iPXE Developer List <ipxe-devel at ipxe.org>
Subject: Re: [ipxe-devel] I have a trouble booting iPXE from a specific laptop

Yes that is probably the issue that Richard Moore mentioned a fix for with using INTEL_NO_PHY_RST, you could confirm by checking if the link speed is just 10mbit instead of gigabit on the switch port. (it is a possible issue and fix now when using ipxe.* instead of undionly.*
build)

Richard: you tested this fix as well and it works on all your machines with this exact nic?


Another mention of the same, and i think there is more:
http://lists.ipxe.org/pipermail/ipxe-devel/2016-September/005174.html

you can find a version of ipxe.pxe with the below patch on top of master that hopefully works at https://b800.org/ipxe.i219-lm2.pxe (I would strongly suggest you build this yourself, but for now you can just download that ipxe.pxe variant and replace your existing
ipxe.pxe)

Also thanks for the bios version numbers, if i get the chance I will try to see what I can find on other Lenovo machines.

The UNDI debug did not give much info, would have to dig much deeper to find more info about what to try in ways of debugging - but if you can you should clearly report to Lenovo that ipxes undionly.kpxe does not work on that machine and that is most likely due to some kind of issue with the machines bios firmware.

diff --git a/src/drivers/net/intel.c b/src/drivers/net/intel.c index 4f8a4cb..ab6defd 100644
--- a/src/drivers/net/intel.c
+++ b/src/drivers/net/intel.c
@@ -1069,7 +1069,7 @@ static struct pci_device_id intel_nics[] = {
        PCI_ROM ( 0x8086, 0x15a1, "i218v-2", "I218-V", 0 ),
        PCI_ROM ( 0x8086, 0x15a2, "i218lm-3", "I218-LM", INTEL_NO_PHY_RST ),
        PCI_ROM ( 0x8086, 0x15a3, "i218v-3", "I218-V", INTEL_NO_PHY_RST ),
-       PCI_ROM ( 0x8086, 0x15b7, "i219lm-2", "I219-LM (2)", 0 ),
+       PCI_ROM ( 0x8086, 0x15b7, "i219lm-2", "I219-LM (2)", 
+ INTEL_NO_PHY_RST ),
        PCI_ROM ( 0x8086, 0x15b8, "i219v-2", "I219-V (2)", 0 ),
        PCI_ROM ( 0x8086, 0x294c, "82566dc-2", "82566DC-2", 0 ),
        PCI_ROM ( 0x8086, 0x2e6e, "cemedia", "CE Media Processor", 0 ),

On Tue, Dec 20, 2016 at 3:49 PM, Esben Storgaard Nielsen <esn at solar.dk> wrote:
> Hi Again
>
>
>
> Ipxe.pxe works also, but it is much slower to boot the “sccm boot image”
> than if I use the ipxe on the USB I have created!
>
> It takes minutes to boot, when I use the USB created from the ISO it 
> takes about 15. Sekunds!
>
>
>
> Med venlig hilsen / Kind regards,
>
>
>
>
>
> Esben Storgaard Nielsen
> Systems Administrator, Server
>
>
>
>
>
> Phone Direct +45 79300314
> Mobile           +45 40342836
> E-mail            esn at solar.dk
> Internet          www.solar.eu
>
>
>
> Solar A/S
> Industrivej Vest 43
> 6600 Vejen
> Phone  79 30 00 00
>
>
>
> From: Christian Nilsson [mailto:nikize at gmail.com]
> Sent: 20. december 2016 14:40
>
>
> To: Esben Storgaard Nielsen <esn at solar.dk>
> Cc: Richard Moore <rich at richud.com>; iPXE Developer List 
> <ipxe-devel at ipxe.org>
> Subject: RE: [ipxe-devel] I have a trouble booting iPXE from a 
> specific laptop
>
>
>
> I´m on the go so quick reply... undionly.kpxe and ipxe.pxe are both 
> pxe NBPs so you can switch them for each other.. prebuilt ones can be 
> found at boot.ipxe.org
>
> On 20 Dec 2016 12:59, "Esben Storgaard Nielsen" <esn at solar.dk> wrote:
>
> Hi Again,
>
> First, I'm sorry, Forgot to inform you about the bios versions.
> I have try it with two version
>
> Lenovo T460P 20FX-S08L00 - With Bios    2.12  (R07ET72W)  ECP 1.04
> (R07HT14W)
> Lenovo T460P 20FX-S17500 - With Bios    2.11  (R07ET71W)  ECP 1.04
> (R07HT14W)
>
> A the moment, I don't have access to an image sharing site, but if 
> necessary I can created one temporally.
>
> If I shall switch to ipxe.pxe, can I still have my menu for chainloading?
> And on (h)ttp://ipxe.org I can't find any documentation how to use 
> ipxe.pxe instead undionly.ipxe
>
> On (h)ttp://ipxe.org/download, can I only find a link to the iso file, 
> and the source code, for the .usb file, it tells me to build by myself!
>
> I can create a virtual computer, but I don't know how to build, so I 
> have used you build.
> I have attached a screen shot, from a pxe boot with you kpxe file, and 
> reduced the size to lowest possible.
>
> I don't know where you are located physically, but if you need access 
> to a virtual computer, then I have access the following remote sharing 
> tools WebEx, TeamViewer and Skype.
>
>
>
> Med venlig hilsen / Kind regards,
>
> Esben Storgaard Nielsen
> Systems Administrator, Server
>
> Solar A/S
> Industrivej Vest 43
> 6600 Vejen
>
> Phone Direct +45 79300314
> Fax
> Mobile       +45 40342836
> E-mail       esn at solar.dk
> Internet     www.solar.eu
> -----Original Message-----
> From: Christian Nilsson [mailto:nikize at gmail.com]
> Sent: 19. december 2016 19:01
> To: Esben Storgaard Nielsen <esn at solar.dk>
> Cc: Richard Moore <rich at richud.com>; iPXE Developer List 
> <ipxe-devel at ipxe.org>
> Subject: RE: [ipxe-devel] I have a trouble booting iPXE from a 
> specific laptop
>
> Hi again,
> The list is limited to a few hundred kb, so we should keep emails 
> below that, images are super helpful, but if possible put them on some 
> image sharing site if possible.
>
> We can see that undionly.kpxe are unable to receive anything (we see 
> that on the [Link:up, TX:4 TXE:1 RX:0 RXE:0] line due to 0 on RX:)
>
> We can also see that ipxe.lkrn that is loaded via iso works just fine.
> (because dhcp is ok and TX and RX is not zero) The "errors" you see 
> from ifstat in this is more informational then errors.
>
> I would suggest you test and switch to ipxe.pxe instead which seems to 
> work at-least on this machine, the question is if you have something 
> else where it does not work. (where ipxe has no native drivers for the 
> nic and there is only UNDI to use)
>
> To debug the original issue you should build with make 
> bin/undionly.kpxe DEBUG=undi,undinet (this is why i earlier mentioned 
> that you should have a build machine, it could be a virtual machine so 
> not much effort is really needed - but for ease of access if you are 
> unable to to do so i built one which you can find at 
> https://b800.org/undionly.undidbg.kpxe )
>
> So far we know that the NIC works just fine with iPXE intel driver 
> (DHCP fine), and it is quite certain that Lenovo has a bug in their 
> BIOS/firmware/NIC ROM build. With the output from above debug build 
> iPXE might be able to implement a workaround.
>
> I personally can't get hold of a T460P which I was hoping for, but it 
> would still be interesting to know which version of the bios this machine has?
>
>
> As a side note, to use the .usb file for usb you could use something 
> like Win32DiskImager, but likely the same tool you used to "copy" the 
> iso to usb supports raw .usb copy as well.
>
> /Christian
>
> On 15 Dec 2016 14:58, "Esben Storgaard Nielsen" <esn at solar.dk> wrote:
>>
>> Hi Christian
>>
>> I have attached a picture where I press CTRL-B  -> DHCP -> IFSTAT
>>
>> I'm a windows user, and not familiar with Linux, so I can't create a 
>> USB drive from the source files.
>>
>> And there is no CD-Rom drive in the computer, but I have created a 
>> USB boot drive from the iPXE.iso file.
>> And that boot seems to work!
>>
>>
>> Med venlig hilsen / Kind regards,
>>
>> Esben Storgaard Nielsen
>> Systems Administrator, Server
>>
>> Solar A/S
>> Industrivej Vest 43
>> 6600 Vejen
>>
>> Phone Direct +45 79300314
>> Fax
>> Mobile       +45 40342836
>> E-mail       esn at solar.dk
>> Internet     www.solar.eu
>> -----Original Message-----
>> From: Christian Nilsson [mailto:nikize at gmail.com]
>> Sent: 14. december 2016 19:17
>> To: Esben Storgaard Nielsen <esn at solar.dk>
>> Cc: Richard Moore <rich at richud.com>; iPXE Developer List 
>> <ipxe-devel at ipxe.org>
>> Subject: Re: [ipxe-devel] I have a trouble booting iPXE from a 
>> specific laptop
>>
>> Hi,
>> Your picture shows "Configuring (net0 xx:xx:xx:xx:xx:xx)....", while 
>> in the forum post the nic is not detected at all (at least the 
>> included text does not show it, maybe that was just not included in 
>> the forum post, other then that it looks similar - but nic found or 
>> not is a big difference)
>>
>> Official build shows (26050) which is as of right now the latest so 
>> that is good.
>>
>> You wrote that they are on slow link, it should not matter but is it 
>> connected to a gigabit port or 100mbit? could you try the other?
>>
>> in that image we also see ifstat with "[Link:up, TX:0 TXE:1 RX:0 RXE:0]"
>> Could we get a pure undionly.kpxe chain boot where ctrl-b is used to 
>> get into shell instead of using any script followed by typing dhcp 
>> and then ifstat - that way we see what gives what. The interesting 
>> part is whater or not we get any kind of RX or RXE at all.
>>
>> it would also be interesting if you could test official ipxe.pxe or 
>> ipxe.usb and see whether or not that works, just to narrow down where 
>> the issue is.
>>
>> I will also try to see if i can get my hands on a T460P and test this 
>> myself. - could you get which bios version your machines is loaded with?
>>
>> /Christian
>>
>> On Wed, Dec 14, 2016 at 10:34 AM, Esben Storgaard Nielsen 
>> <esn at solar.dk>
>> wrote:
>> > Hi All
>> >
>> > Thank you for trying helping me, solving this issue.
>> >
>> > I will try to answer all of you mails, I'm from Denmark, I just 
>> > arrived at my job today.
>> >
>> > @ Christians first mail
>> >
>> > I our environment we have about 100 different subnets, and lot of 
>> > them are on slow link.
>> > We use Microsoft SCCM for handling client OS, so to ensure we use 
>> > http instead of tftp we use undionly.kpxe We also use it for adding 
>> > other boot options, I have attached a menu sample, used on 
>> > rom-o-matic
>> >
>> > @ the specific Lenovo model, it is a Lenovo T460P 20FX-S08L00 and
>> > 20FX-S17500
>> >
>> > @ the link I posted
>> > http://forum.ipxe.org/showthread.php?tid=7713&highlight=i219 it 
>> > look exact the same on my computer, I have attached a picture of the boot screen.
>> >
>> > @  Officially build undionly.kpxe have I attached a picture
>> >
>> > @ I have a machine for testing, and a subnet where I can change the 
>> > pxe boot options, but I'm a technician so I'm not expert on 
>> > building  software by myself.
>> >
>> > @ Richards mail
>> >  I have tried to fully discharge the computer.
>> >
>> >
>> > Med venlig hilsen / Kind regards,
>> >
>> > Esben Storgaard Nielsen
>> > Systems Administrator, Server
>> >
>> > Solar A/S
>> > Industrivej Vest 43
>> > 6600 Vejen
>> >
>> > Phone Direct +45 79300314
>> > Fax
>> > Mobile       +45 40342836
>> > E-mail       esn at solar.dk
>> > Internet     www.solar.eu
>> > -----Original Message-----
>> > From: Christian Nilsson [mailto:nikize at gmail.com]
>> > Sent: 13. december 2016 20:39
>> > To: Richard Moore <rich at richud.com>
>> > Cc: Esben Storgaard Nielsen <esn at solar.dk>; iPXE Developer List 
>> > <ipxe-devel at ipxe.org>
>> > Subject: Re: [ipxe-devel] I have a trouble booting iPXE from a 
>> > specific laptop
>> >
>> > Just in case it was unclear: if undionly.kpxe is used then what is 
>> > in the intel.c driver does not matter since undionly means what it 
>> > says, only the PXE UNDI stack is use.
>> >
>> > in case ipxe.pxe is used instead than that flag can make a 
>> > difference but so far I have only seen that flag affect link speed 
>> > and not link up, so on some intel nic that flag is needed to enable 
>> > gigabit linkup (sometimes but not always), otherwise it might end up on only 10mbit link instead.
>> >
>> > On Tue, Dec 13, 2016 at 8:13 PM, Richard Moore <rich at richud.com> wrote:
>> >> Hi Esben,
>> >>
>> >> The git master (rom-o-matic) uses has this in intel.c
>> >>
>> >> PCI_ROM ( 0x8086, 0x15b7, "i219lm-2", "I219-LM (2)", 0 ),
>> >>
>> >> it probably needs to be
>> >>
>> >> PCI_ROM ( 0x8086, 0x15b7, "i219lm-2", "I219-LM (2)", 
>> >> INTEL_NO_PHY_RST ),
>> >>
>> >>
>> >> ...otherwise it wont work in some machines with that chip (out of 
>> >> 4 different types of HP machines I tested with, one needs 
>> >> INTEL_NO_PHY_RST and other three are ok)
>> >>
>> >>
>> >> You will need to build yours from source (changing that line) and 
>> >> try it, rather than use rom-o-matic.
>> >>
>> >>
>> >>
>> >> Cheers
>> >>
>> >> Rich
>> >>
>> >>
>> >>
>> >>
>> >> On Tue, 2016-12-13 at 15:08 +0000, Esben Storgaard Nielsen wrote:
>> >>
>> >> Hi again
>> >>
>> >>
>> >> If i look in the net card setup menu, I can see a small diference
>> >>
>> >> T460P PCI ID 8086/15B7/17AA/5050/31   Don't work
>> >> T460  PCI ID 8086/156F/17AA/2233/21   Works
>> >>
>> >>
>> >> Med venlig hilsen / Kind regards,
>> >>
>> >> Esben Storgaard Nielsen
>> >> Systems Administrator, Server
>> >>
>> >> Solar A/S
>> >> Industrivej Vest 43
>> >> 6600 Vejen
>> >>
>> >> Phone Direct +45 79300314
>> >> Fax
>> >> Mobile       +45 40342836
>> >> E-mail       esn at solar.dk
>> >> Internet     www.solar.eu
>> >>
>> >> -----Original Message-----
>> >> From: Richard Moore [mailto:rich at richud.com]
>> >> Sent: 13. december 2016 15:18
>> >> To: Esben Storgaard Nielsen <esn at solar.dk>
>> >> Subject: Re: [ipxe-devel] I have a trouble booting iPXE from a 
>> >> specific laptop
>> >>
>> >> Check the net card's hardware  dev/ven are in here, 
>> >> src/drivers/net/intel.c
>> >>
>> >> Should be something like
>> >>
>> >>
>> >>       PCI_ROM ( 0x8086, 0x15a0, "i218lm-2", "I218-LM", 
>> >> INTEL_NO_PHY_RST ),
>> >>       PCI_ROM ( 0x8086, 0x15a1, "i218v-2", "I218-V", 0 ),
>> >>       PCI_ROM ( 0x8086, 0x15a2, "i218lm-3", "I218-LM", 
>> >> INTEL_NO_PHY_RST ),
>> >>       PCI_ROM ( 0x8086, 0x15a3, "i218v-3", "I218-V", 
>> >> INTEL_NO_PHY_RST ),
>> >>       PCI_ROM ( 0x8086, 0x15b7, "i219lm-2", "I219-LM (2)", 
>> >> INTEL_NO_PHY_RST ),
>> >>       PCI_ROM ( 0x8086, 0x15b8, "i219v-2", "I219-V (2)", 0 ),
>> >>
>> >>
>> >>
>> >>
>> >> Cheers
>> >>
>> >> Rich
>> >>
>> >>
>> >>
>> >>
>> >> Hi Again
>> >>
>> >> I still have some trouble bootin iPXE from 1 type of computer.
>> >> Lenovo tells me, that they can’t help because the net card 
>> >> isn’t on a compatibility list from iPXE.
>> >> That’s correct, http://ipxe.org/appnote/hardware_drivers
>> >>
>> >> The net card used is an “Intel i219LM“
>> >>
>> >> I use undionly.kpxe and use the site https://rom-o-matic.eu/ for 
>> >> building my file, and here is the net card is presented on the net 
>> >> card list.
>> >> So I think that the compatibility list isn’t updated.
>> >>
>> >> I can see on the FAQ forum that the problem has being reported 
>> >> once before.
>> >> http://forum.ipxe.org/showthread.php?tid=7713&highlight=i219
>> >>
>> >> I can’t see where I can try the suggestion, there is no option 
>> >> in the advance section on rom-o-matic.eu
>> >>
>> >>
>> >> Could you came with some suggestions, so I can get further with 
>> >> this task.
>> >>
>> >>
>> >> Med venlig hilsen / Kind regards,
>> >>
>> >>
>> >>
>> >>
>> >>
>> >>
>> >> Esben Storgaard Nielsen
>> >> Systems Administrator, Server
>> >>
>> >> [http://emailsignature.solar.eu/General/Solar_Logo.jpg]
>> >>
>> >>
>> >>
>> >>
>> >>
>> >> Phone Direct +45 79300314
>> >> Mobile           +45 40342836
>> >> E-mail            esn at solar.dk<mailto:esn at solar.dk>
>> >> Internet          www.solar.eu<http://www.solar.eu/>
>> >>
>> >>
>> >>
>> >> Solar A/S
>> >> Industrivej Vest 43
>> >> 6600 Vejen
>> >> Phone  79 30 00 00
>> >>
>> >>
>> >> From: Christian Nilsson [mailto:nikize at gmail.com]
>> >> Sent: 25. november 2016 01:11
>> >> To: Esben Storgaard Nielsen <esn at solar.dk>
>> >> Cc: ipxe-devel at lists.ipxe.org
>> >> Subject: Re: [ipxe-devel] I have a trouble booting iPXE from a 
>> >> specific laptop
>> >>
>> >> In the image it looks like you have BIOS doing PXE DHCP request, 
>> >> getting response and loading some version of ipxe.
>> >> After that you should have another DHCP request but this time from 
>> >> iPXE, is this second dhcp request seen by the dhcp server?
>> >>
>> >> The ipxe in the image is missing the "git version id" please make 
>> >> sure you have the latest version of ipxe git master and that the 
>> >> git version id is shown when booting.
>> >>
>> >> One thing that might be interesting is if you press ctrl-b to get 
>> >> the iPXE shell and then type dhcp enter followed by ifstat to get 
>> >> some info about nic driver and how it looks in regards to packets 
>> >> received and sent and any possible error.
>> >>
>> >> You are using ipxe.pxe? have you tried undionly.kpxe instead?
>> >>
>> >> /Christian
>> >>
>> >> On Thu, Nov 24, 2016 at 11:37 AM, Esben Storgaard Nielsen 
>> >> <esn at solar.dk<mailto:esn at solar.dk>> wrote:
>> >> Hi
>> >>
>> >> We using IPXE to boot our SCCM boot image, and its works very fine.
>> >>
>> >> But now we got at strange issue, with a new Lenovo T460P laptop.
>> >>
>> >> When we try booting PXE, I got a ip address, and it contact the 
>> >> iPXE server, and on the tftp log, we can see it sends the boot 
>> >> menu file, but nothing happens on the laptop.
>> >> When we use the T460 there is no problems.
>> >> And both computers have the same net card.
>> >>
>> >> Any suggestions to solve my issue?
>> >>
>> >> I have attached a picture of the failure computer.
>> >>
>> >>
>> >>
>> >>
>> >> Med venlig hilsen / Kind regards,
>> >>
>> >>
>> >>
>> >>
>> >>
>> >>
>> >> Esben Storgaard Nielsen
>> >> Systems Administrator, Server
>> >>
>> >>
>> >>
>> >>
>> >>
>> >>
>> >>
>> >> Phone Direct +45 79300314<tel:%2B45%2079300314>
>> >> Mobile           +45 40342836<tel:%2B45%2040342836>
>> >> E-mail            esn at solar.dk<mailto:esn at solar.dk>
>> >> Internet          www.solar.eu<http://www.solar.eu/>
>> >>
>> >>
>> >>
>> >> Solar A/S
>> >> Industrivej Vest 43
>> >> 6600 Vejen
>> >> Phone  79 30 00 00
>> >>
>> >> <http://www.linkedin.com/company/14368?trk=tyah&trkInfo=tas%3Asola
>> >> r
>> >> %2
>> >> 0
>> >> A%2FS%2Cidx%3A1-1-1>
>> >>
>> >>
>> >> <http://www.linkedin.com/company/14368?trk=tyah&trkInfo=tas%3Asola
>> >> r
>> >> %2
>> >> 0
>> >> A%2FS%2Cidx%3A1-1-1>
>> >>
>> >>
>> >> <http://www.linkedin.com/company/14368?trk=tyah&trkInfo=tas%3Asola
>> >> r
>> >> %2
>> >> 0
>> >> A%2FS%2Cidx%3A1-1-1>
>> >>
>> >>
>> >>
>> >> <http://www.linkedin.com/company/14368?trk=tyah&trkInfo=tas%3Asola
>> >> r
>> >> %2
>> >> 0
>> >> A%2FS%2Cidx%3A1-1-1>
>> >>
>> >> _______________________________________________
>> >> ipxe-devel mailing list
>> >> ipxe-devel at lists.ipxe.org
>> >> https://lists.ipxe.org/mailman/listinfo.cgi/ipxe-devel<http://www.
>> >> l
>> >> in
>> >> k
>> >> edin.com/company/14368?trk=tyah&trkInfo=tas%3Asolar%20A%2FS%2Cidx%
>> >> 3
>> >> A1
>> >> -
>> >> 1-1>
>> >> <http://www.linkedin.com/company/14368?trk=tyah&trkInfo=tas%3Asola
>> >> r
>> >> %2
>> >> 0 A%2FS%2Cidx%3A1-1-1>
>> >> _______________________________________________
>> >> ipxe-devel mailing list
>> >> ipxe-devel at lists.ipxe.org
>> >> https://lists.ipxe.org/mailman/listinfo.cgi/ipxe-devel
>> >>
>> >>
>> >>
>> >>


More information about the ipxe-devel mailing list