[ipxe-devel] Issues chainbooting iPXE to WDS 2012R2

Hummel Frank F.Hummel at ads-tec.de
Tue Apr 15 13:08:06 BST 2014


Well – found that sequence to be functional by trial-and-error.
Did you try it?

As far as the fonts are concerned - I do not use older bootmgr versions.
If you don't load the fonts (there are other sets for older bootmgr) you will not see error messages if the PE does not boot successfully.
You will just see a black or blue (not BSOD) screen...

mit freundlichen Grüßen
with kind regards

i. A. Dipl.Ing. (FH) Frank Hummel
Systementwicklung
System development

ads-tec GmbH
Raiffeisenstr.14
70771 Leinfelden-Echterdingen
Germany

Tel.:    +49 711 45894-220
Fax:    +49 711 45894-987
E-Mail: F.Hummel at ads-tec.de
Web: www.ads-tec.de




Von: Ian Bannerman [mailto:ian at internals.io] 
Gesendet: Dienstag, 15. April 2014 13:23
An: Hummel Frank; Nicholas Krouse; ipxe-devel at lists.ipxe.org
Betreff: RE: [ipxe-devel] Issues chainbooting iPXE to WDS 2012R2

That's odd. I have not encountered any issues using a similar set up to this - initrd winpe/${arch}/winpe.wim winpe.wim ← Names must match and must match the entry in your bcd!

Are you sure that's a requirement? If boot.wim matches the reference in the BCD this should be fine.

My understanding is also that fonts are only required for Windows 8 and newer WIM/bootmgr combos.

--Ian
> Date: Tue, 15 Apr 2014 09:30:44 +0200
> From: F.Hummel at ads-tec.de
> To: nicholas.krouse at nccvt.k12.de.us; ipxe-devel at lists.ipxe.org
> Subject: Re: [ipxe-devel] Issues chainbooting iPXE to WDS 2012R2
> 
> Hi,
> 
> :wds-server
> dhcp
> set wdsserver 10.200.0.74
> set alternatetftp 10.200.0.74
> set net0/dhcp-server ${wdsserver}
> set net0/filename wdsbnp.com ← Typo, not the cause for the current prob
> set net0/gateway ${wdsserver}
> set net0/next-server ${wdsserver}
> set net0/user-class PXEClient
> -------------------------------------------------------------------
> Your sequence:
> :wimboot
> cpuid --ext 29 && set arch amd64 || set arch x86
> kernel wimboot
> initrd winpe/${arch}/ISO/bootmgr bootmgr
> initrd winpe/${arch}/ISO/boot/bcd BCD
> initrd winpe/${arch}/ISO/boot/boot.sdi boot.sdi
> initrd winpe/${arch}/winpe.wim boot.wim
> boot || goto failed
> goto start
> -------------------------------------------------------------------
> You are missing the fonts and left and right must look the same. Should look like this:
> 
> :wimboot
> cpuid --ext 29 && set arch amd64 || set arch x86
> kernel wimboot
> initrd winpe/${arch}/ISO/bootmgr bootmgr
> initrd winpe/${arch}/ISO/boot/bcd bcd ← take care! Case sensitive!
> initrd winpe/${arch}/ISO/boot/boot.sdi boot.sdi
> initrd winpe/${arch}/ISO/boot/segmono_boot.ttf segmono_boot.ttf
> initrd winpe/${arch}/ISO/boot/segoe_slboot.ttf segoe_slboot.ttf
> initrd winpe/${arch}/ISO/boot/segoen_slboot.ttf segoen_slboot.ttf
> initrd winpe/${arch}/ISO/boot/wgl4_boot.ttf wgl4_boot.ttf
> initrd winpe/${arch}/winpe.wim winpe.wim ← Names must match and must match the entry in your bcd!
> Imgstat ← enables you to see if all files have been loaded
> prompt ← stops until you continue after reading imgstat output
> boot || goto failed
> goto start
> 
> My experience with wimboot is that it is quite unreliable. Sometimes it works, sometimes not - depending on the boot.wim file. But I could not find out why it fails with some wim-files and succeeds with others.
> That's why I use syslinux memdisk and the ISO file containing the very same wim-file failing with wimboot which always works.
> E.g.:
> set sanboot-url http://123.456.789.012
> initrd ${sanboot-url}/win7pe_x86.iso
> chain syslinux/memdisk iso raw
> 
> 
> 
> mit freundlichen Grüßen
> with kind regards
> 
> i. A. Dipl.Ing. (FH) Frank Hummel
> Systementwicklung
> System development
> 
> ads-tec GmbH
> Raiffeisenstr.14
> 70771 Leinfelden-Echterdingen
> Germany
> 
> Tel.:    +49 711 45894-220
> Fax:    +49 711 45894-987
> E-Mail: F.Hummel at ads-tec.de
> Web: www.ads-tec.de
> 
> 
> 
> 
> Von: ipxe-devel-bounces at lists.ipxe.org [mailto:ipxe-devel-bounces at lists.ipxe.org] Im Auftrag von Nicholas Krouse
> Gesendet: Montag, 14. April 2014 20:22
> An: ipxe-devel at lists.ipxe.org
> Betreff: [ipxe-devel] Issues chainbooting iPXE to WDS 2012R2
> 
> Hello 
> 
> I use iPXE for my main boot menu in my classroom for my students. When I attempt to chainboot to my WDS Server 2012 r2 I get error 0x3d126001 and the boot fails. I have searched google and ipxe forums high and low looking for a solution. I use wds over wimboot as it make management of my wim files quick and easy for me and my students. If there is any way you could help me it would be greatly appreciated! Attached is my current menu.ipxe. Thanks for your time in advance.
> 
> Thanks
> Nick Krouse
> Computer Support Instructor
> Delaware Skills Center
> Deskillscenter.org
> _______________________________________________
> ads-tec GmbH
> Sitz: 70771 Leinfelden-Echterdingen
> Registergericht Stuttgart HRB 224527
> 
> Geschaeftsfuehrer:
> Dipl.-Ing. Thomas Speidel
> _______________________________________________
> Diese E-Mail enthaelt vertrauliche und/oder rechtlich
> geschuetzte Informationen. Wenn Sie nicht der richtige
> Adressat sind oder diese E-Mail irrtuemlich erhalten
> haben, informieren Sie bitte sofort den Absender und 
> vernichten Sie diese E-Mail. Das unerlaubte Kopieren,
> jegliche anderweitige Verwendung sowie die unbefugte
> Weitergabe dieser Mail sind nicht gestattet.
> _______________________________________________
> 
> This e-mail may contain confidential and/or privileged
> information. If you are not the intended recipient (or have
> received this e-mail in error) please notify the sender
> immediately and destroy this e-mail. Any unauthorized
> copying, disclosure, distribution or other use of the
> material or parts thereof are strictly forbidden.
> _______________________________________________
> _______________________________________________
> ipxe-devel mailing list
> ipxe-devel at lists.ipxe.org
> https://lists.ipxe.org/mailman/listinfo.cgi/ipxe-devel
_______________________________________________
ads-tec GmbH
Sitz: 70771 Leinfelden-Echterdingen
Registergericht Stuttgart HRB 224527

Geschaeftsfuehrer:
Dipl.-Ing. Thomas Speidel
_______________________________________________
Diese E-Mail enthaelt vertrauliche und/oder rechtlich
geschuetzte Informationen. Wenn Sie nicht der richtige
Adressat sind oder diese E-Mail irrtuemlich erhalten
haben, informieren Sie bitte sofort den Absender und 
vernichten Sie diese E-Mail. Das unerlaubte Kopieren,
jegliche anderweitige Verwendung sowie die unbefugte
Weitergabe dieser Mail sind nicht gestattet.
_______________________________________________

This e-mail may contain confidential and/or privileged
information. If you are not the intended recipient (or have
received this e-mail in error) please notify the sender
immediately and destroy this e-mail. Any unauthorized
copying, disclosure, distribution or other use of the
material or parts thereof are strictly forbidden.
_______________________________________________


More information about the ipxe-devel mailing list