[ipxe-devel] [gPXE] gPXE 0.9.3 build problem if with e1000e driver from gPXE 1.0.1

Michael Brown mbrown at fensystems.co.uk
Sun Mar 18 20:29:23 GMT 2012


On Sunday 18 Mar 2012 19:36:33 Edwin Li wrote:
> What I Did:
> 
> 1) download and build gPXE 0.9.3, everything is ok under Linux 2.6.35 or
> 2.6.39 2) ported e1000e driver from gPXE 1.0.1 and added the e1000e whole
> folder to gPXE 0.9.3 at src/drivers/net/e1000e 3) commented out all lines
> of "FILE_LICENCE ( GPL2_OR_LATER );"
> 4) added "SRCDIRS         += drivers/net/e1000e" to Makefile
> 5) make (or, make veryclean; make)
> 
> The Problem:
> <snip>

gPXE 0.9.3 is four years old.

a) Why would you expect that to work?

b) Why would you want to do it?

c) Why not simply upgrade to iPXE?  (gPXE is no longer maintained.)

Michael


More information about the ipxe-devel mailing list