[ipxe-devel] aes.o compile error

Rob Shelley Rob at cirris.com
Thu Mar 15 00:04:17 GMT 2012


Yes that also solved the problem.

Rob


-----Original Message-----
From: Michael Brown [mailto:mbrown at fensystems.co.uk] 
Sent: Tuesday, March 13, 2012 6:16 PM
To: ipxe-devel at lists.ipxe.org
Cc: Rob Shelley
Subject: Re: [ipxe-devel] aes.o compile error

On Tuesday 13 Mar 2012 20:31:57 Rob Shelley wrote:
> Dylan got me all squared away.  I was running this with gcc 4.5-19.1 
> on an opensuse 11.4 system.  Apparently the default is to treat 
> warnings as errors.  Running 'make -Werror' fixed my problem.  Sorry 
> for the noob question.

Sorry about that.  iPXE _should_ generally work when compiled with -Werror; the code is designed to be warning-free.  I've applied a patch that should hopefully fix the problem and allow you to build without any hacks:

  http://git.ipxe.org/ipxe.git/commitdiff/37cb7c7

Michael


More information about the ipxe-devel mailing list