[ipxe-devel] WinPE 3.0, boot with iSCSI target

Slawomir Latkowski slawomir.latkowski at gmail.com
Wed Mar 14 23:01:14 GMT 2012


Hi Marek,

Yes you are right, according to this tutorial it will boot live cd and allow to mount the iSCSI target after.

Best regards
Slawomir Latkowski

Sent from iPhone

On 14 Mar 2012, at 11:14, Marek Salwerowicz <marek_sal at wp.pl> wrote:

> Hi,
> 
> W dniu 2012-03-14 01:09, Slawomir Latkowski pisze:
>> Hi Marek,
>> 
>> I don't think it will boot from iSCSI target.
>> The tutorial you were following says about (...I have dedicated my
>> time to figuring out a way to mount iSCSI targets under our custom
>> WinPE v3.0 (Windows 7 Based) environment...) but not to boot from
>> iSCSI target.
> As far as I know, sanboot allows to boot the Live-CD image (like my WinPE ISO).
> What's more, when I do not set iSCSI Target ( sanhook....) and ONLY boot Live-CD, everything works.
> 
> 
> -- 
> Regards,
> Marek Salwerowicz
> 
>> 
>> Maybe I miss a point...
>> 
>> Regards,
>> Slawek
>> 
>> W dniu 13 marca 2012 23:51 użytkownik Marek Salwerowicz
>> <marek_sal at wp.pl>  napisał:
>>> Hi list,
>>> 
>>> I have a problem with trying to boot WinPE 3.0 (prepared according to:
>>> http://www.gregorystrike.com/2010/01/08/winpe-v3-0-and-microsoft-iscsi-initiator/).
>>> I've prepared it under Win7 Pro.
>>> 
>>> I have downladed from git repository current tree, prepared the ISO image of
>>> iPXE (under Debian Squeeze)
>>> 
>>> I have set up the iSCSI target under FreeNAS
>>> 
>>> After booting my machine from iPXE ISO image i type following commands:
>>> 
>>> dhcp
>>> set keep-san 1
>>> sanhook --drive 0x80 --no-describe
>>> iscsi:192.168.146.132::::iqn.2012-01.local:win7disk
>>> sanboot --drive 0x81 --no-describe http://10.0.0.1/path.to.WinPE.iso
>>> 
>>> WinPE stops during boot and displays following message:
>>> 
>>> File: \Boot\BCD
>>> Status: 0xc000000e
>>> Info: An error occurred while attempting to read the boot configuration
>>> data.
>>> 
>>> When I do not attach iSCSI target and only boot the WinPE iso file,
>>> everything is OK, but (of course) I can't install Windows under my iSCSI
>>> target.
>>> 
>>> Does anyone have an idea what I am doing wrong?
>>> 
>>> --
>>> Regards,
>>> Marek Salwerowicz
>>> 
>>> 
>>> 
>>> 
>>> _______________________________________________
>>> ipxe-devel mailing list
>>> ipxe-devel at lists.ipxe.org
>>> https://lists.ipxe.org/mailman/listinfo/ipxe-devel
> 


More information about the ipxe-devel mailing list